1
Vote

Enterprise Library Config Tool Crashes

description

Hi:
 
I copied both Assemblies to EntLib Folder (by the way i am using Enterprise Library 3.1)
 
Sprydon.AuthenticatingEmailTraceListener.Configuration.Design.dll
Sprydon.AuthenticatingEmailTraceListener.dll
 
When i tried to open Config Utility after copying i am getting a error mesage attached as JPG.
 
Please advise.
 
Thanks,
Sriram.

file attachments

comments

srizzler wrote Aug 12, 2008 at 10:22 AM

Can you please provide those assemblies which are compatible with Enterprise Library 3.1 ?

srizzler wrote Aug 12, 2008 at 11:53 AM

I re-compiled your source code with Enterprise Library 3.1 dll's which you used in both the projects i.e. AuthenticatingEmailTraceListener, AuthenticatingEmailTraceListener.Configuration.Design. Later i copied updated assemblies to EntLib Folder. With Ent Lib Config Tool i can able to add new Trace Listener "Authenticating Email Trace Listener", i supplied all neccessary values for Authenticating Emails.

When i tried to use it thru application iam getting attached error. Please help me out.

Thanks,
Sriram.

PS : I observed one strange behaviour, even though i am providing value for formatter as "Text Formatter", it is resetting back to "none" when i reopens app.config with tool next time. This might be the cause for the error.

wrote Aug 12, 2008 at 11:53 AM

srizzler wrote Aug 12, 2008 at 12:30 PM

Error Line of Config File which i attached with AnotherException.jpg is :

listenerDataType="Sprydon.TraceListeners.Configuration.AuthenticatingEmailTraceListenerData, Sprydon.AuthenticatingEmailTraceListener, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null"

wrote Feb 2, 2013 at 5:29 AM